18 tháng 1, 2008

sample lab topologies for Vlan trunk


# Simple Ethernet Switch lab
# cau hinh nay da duoc toi u tren may tinh cong ty
autostart = False

[localhost]
ghostios = true
sparsemem = true
mmap = True
workingdir = D:\Working\DYNAGEN\1R3745-2SW2691-4PC3620
[[3745]]
image = C:\Program Files\Dynamips\images\c3745-adventerprisek9-mz.124-12.bin
ram = 160
slot2 = NM-4T
[[2691]]
image = C:\Program Files\Dynamips\images\c2691-entbasek9-mz.124-12.bin
ram = 128
slot1 = NM-16ESW
[[3620]]
image = C:\Program Files\Dynamips\images\c3620-io3-mz.122-32.bin
ram = 32
slot1 = NM-1E

[[ROUTER SW1]]
model = 2691
f1/12 = SW2 f1/12
f1/1 = PC1 f0/0
# 192.168.1.1
f1/2 = PC2 f0/0 # 192.168.2.1
console = 2005
idlepc = 0x60691994

[[ROUTER SW2]]
model = 2691
f1/1 = PC3 f0/0 # 192.168.1.2
f1/2 = PC4 f0/0 # 192.168.2.2
console = 2006
idlepc = 0xffffffff8000ad08

[[router R1]]
model = 3745
console = 2007
f0/0 = SW1 f1/0
idlepc = 0xffffffff8000a8ac
#idlepc = 0xffffffff8000b4d8
#idlepc = 0xffffffff8000b518
[[router PC1]]
model = 3620
console = 2011
idlepc = 0xffffffff8000a154
#idlepc = 0xffffffff8000ac28
[[router PC2]]
model = 3620
console = 2008
idlepc = 0xffffffff8000a154
#idlepc = 0xffffffff8000ac88
[[router PC3]]
model = 3620
console = 2009
idlepc = 0xffffffff8000a154
#idlepc = 0xffffffff8000ac28
[[router PC4]]
model = 3620
console = 2010
idlepc = 0xffffffff8000ac28

PC1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
PC1(config)#no ip routing
PC1(config)#ip default-gateway 192.168.1.10
PC1(config)#interface e0/0
PC1(config-if)#ip address 192.168.1.1 255.255.255.0
PC1(config-if)#no shutdown
PC1(config-if)#end
PC1#
PC2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
PC2(config)#no ip routing
PC2(config)#ip default-gateway 192.168.2.20
PC2(config)#interface e0/0
PC2(config-if)#ip address 192.168.2.1 255.255.255.0
PC2(config-if)#no shutdown
PC2(config-if)#end
PC2#
PC3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
PC3(config)#no ip routing
PC3(config)#ip default-gateway 192.168.1.10
PC3(config)#interface e0/0
PC3(config-if)#ip address 192.168.1.2 255.255.255.0
PC3(config-if)#no shutdown
PC3(config-if)#end
PC3#
PC4#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
PC4(config)#no ip routing
PC4(config)#ip default-gateway 192.168.2.20
PC4(config)#interface e0/0
PC4(config-if)#ip address 192.168.2.2 255.255.255.0
PC4(config-if)#no shutdown
PC4(config-if)#end
PC4#
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface FastEthernet0/0
R1(config-if)#no shutdown
R1(config-if)#interface FastEthernet0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.1.10 255.255.255.0
R1(config-subif)#interface FastEthernet0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.2.20 255.255.255.0
R1(config-subif)#end
R1#

------SW1-------
SW1#vlan database
SW1(vlan)#vlan 10 name vlan10
VLAN 10 modified:
Name: vlan10
SW1(vlan)#vlan 20 name vlan20
VLAN 20 added:
Name: vlan20
SW1(vlan)#exit
APPLY completed.
Exiting....
SW1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
SW1(config)#interface f1/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 10
SW1(config-if)#no shutdown
SW1(config-if)#exit
SW1(config)#interface f1/2
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20
SW1(config-if)#no shutdown
SW1(config-if)#exit
SW1(config)#interface f1/12
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#no shutdown
SW1(config-if)#exit
SW1(config)#interface f1/0
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#no shutdown
SW1(config-if)#end
SW1#
------SW2-------
SW2#vlan database
SW2(vlan)#vlan 10 name vlan10
VLAN 10 modified:
Name: vlan10
SW2(vlan)#vlan 20 name vlan20
VLAN 20 modified:
Name: vlan20
SW2(vlan)#exit
APPLY completed.
Exiting....
SW2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
SW2(config)#interface f1/1
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10
SW2(config-if)#no shutdown
SW2(config-if)#exit
SW2(config)#interface f1/2
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 20
SW2(config-if)#no shutdown
SW2(config-if)#exit
SW2(config)#interface f1/12
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#no shutdown
SW2(config-if)#end
SW2#
-->đọc tiếp...

File config cho LAB VLAN - TRUNK (1ROUTER - 2 SWITCH - 4 PC)

# Simple Ethernet Switch lab
# cau hinh nay da duoc toi u tren may tinh cong ty
autostart = False

[localhost]
ghostios = true
sparsemem = true
mmap = True
workingdir = D:\Working\DYNAGEN\1R3745-2SW2691-4PC3620
[[3745]]
image = C:\Program Files\Dynamips\images\c3745-adventerprisek9-mz.124-12.bin
ram = 160
slot2 = NM-4T
[[2691]]
image = C:\Program Files\Dynamips\images\c2691-entbasek9-mz.124-12.bin
ram = 128
slot1 = NM-16ESW
[[3620]]
image = C:\Program Files\Dynamips\images\c3620-io3-mz.122-32.bin
ram = 32
slot1 = NM-1E

[[ROUTER SW1]]
model = 2691
f1/12 = SW2 f1/12
f1/1 = PC1 f0
f1/2 = PC2 f0
console = 2005
idlepc = 0x60691994

[[ROUTER SW2]]
model = 2691
f1/1 = PC3 f0 # 192.168.1.2
f1/2 = PC4 f0 # 192.168.2.2
console = 2006
idlepc = 0xffffffff8000ad08

[[router R1]]
model = 3745
console = 2007
f0/0 = SW1 f1/3
idlepc = 0xffffffff8000a8ac
#idlepc = 0xffffffff8000b4d8
#idlepc = 0xffffffff8000b518
[[router PC1]]
model = 3620
console = 2011
idlepc = 0xffffffff8000a154
#idlepc = 0xffffffff8000ac28
[[router PC2]]
model = 3620
console = 2008
idlepc = 0xffffffff8000a154
#idlepc = 0xffffffff8000ac88
[[router PC3]]
model = 3620
console = 2009
idlepc = 0xffffffff8000a154
#idlepc = 0xffffffff8000ac28
[[router PC4]]
model = 3620
console = 2010
idlepc = 0xffffffff8000ac28
Lien lac qua mail neu can ios nhu cau hinh tren. (nguyen.huu.nguyen@gmail.com -> Subject-Yeu cau ios) toi se gui cho ban. cheers!
-->đọc tiếp...

Lab thuc hanh SW CISCO VLAN TRUNK

# Simple Ethernet Switch lab
autostart = False

[localhost]
ghostios = true
sparsemem = true
mmap = True
workingdir = D:\Working\DYNAGEN\2R7200-2SW3745
[[7200]]
image = C:\Program Files\Dynamips\images\c7200-adventerprisek9-mz.124-11.T.bin
ram = 256
[[3640]]
image = C:\Program Files\Dynamips\images\c3640-is-mz.12.1-4.bin
ram = 64
slot1 = NM-1E
[[3745]]
image = C:\Program Files\Dynamips\images\c3745-adventerprisek9-mz.124-12.bin
ram = 128
slot1 = NM-16ESW

[[ROUTER SW1]]
model = 3745
f1/12 = SW2 f1/12
f1/1 = NIO_gen_eth:\Device\NPF_{31AC8C18-4890-4BC5-A1F0-637C4207965D} # PC1 192.168.1.1
f1/2 = PC2 f0
console = 2005
idlepc = 0xffffffff8000b4d8

[[ROUTER SW2]]
model = 3745
f1/1 = PC3 f0 # 192.168.1.2
f1/2 = PC4 f0 # 192.168.2.2
console = 2006
idlepc = 0xffffffff8000b4d8

[[router R1]]
model = 7200
console = 2007
slot1 = PA-2FE-TX
slot2 = PA-8T
f1/0 = SW1 f1/3
f1/1 = NIO_gen_eth:\Device\NPF_{189EC664-276C-42FE-9C80-9C6B7B7415E0} # PC5 192.168.1.1
idlepc = 0x614a04f4
[[router PC2]]
model = 3640
console = 2008
idlepc = 0x603503a0
[[router PC3]]
model = 3640
console = 2009
idlepc = 0x6036e2a8
[[router PC4]]
model = 3640
console = 2010
idlepc = 0xffffffff83ff7844
-->đọc tiếp...

17 tháng 1, 2008

VLAN Trunking

Mô tả
–VLAN cho phép kết hợp các port trên switch thành các nhóm để giảm lưu lượng broadcast trên mạng. Các lưu lượng này được giới hạn trong phạm vi được xác định bởi VLAN.
–Kết nối trunk là liên kết point-to-point giữa các port trên switch với router hoặc với switch khác. Kết nối trunk sẽ vận chuyển thông tin của nhiều VLAN thông qua 1 liên kết đơn và cho phép mở rộng VLAN trên hệ thống mạng.
–VTP (VLAN Trunking Protocol) là giao thức hoạt động ở Layer 2 trong mô hình OSI. VTP giúp cho việc cấu hình VLAN luôn đồng nhất khi thêm, xoá, sửa thông tin về VLAN trong hệ thống mạng.
–Bài thực hành này mô tả cách thức tạo trunk giữa 2 switch. Trunking được cấu hình trên port F0/1 của hai switch. Ta nên dùng cáp chéo để nối hai port này.
Cấu hình
Switch DL1
!
hostname DL1
!
enable password cisco
!
interface FastEthernet0/1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 30
switchport mode access
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
!
interface Vlan10
ip address 192.168.10.2 255.255.255.0
!
interface Vlan20
ip address 192.168.20.2 255.255.255.0
!
interface Vlan30
ip address 192.168.30.2 255.255.255.0
!
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end
SwitchAL1
!
hostname AL1
!
enable password cisco
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 30
switchport mode access
!
interface VLAN1
ip address 192.168.1.3 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line vty 0 4
mật khẩu cisco
login
line vty 5 15
mật khẩu cisco
login
!
end
Thực hiện
Cấu hình trên Switch DL1 làm VTP Server
1. Đặt hostname, mật khẩu và cấu hình cổng vlan trên DL1:

Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname DL1
DL1(config)#enable password cisco
DL1(config)#line vty 0 15
DL1(config-line)#password cisco
DL1(config-line)#login
DL1(config-line)#exit
DL1(config)#int vlan 1
DL1(config-if)#ip address 192.168.1.3 255.255.255.0
DL1(config-if)#end
DL1#
2. Thiết lập VTP domain là VNPRO, VTP mode là SERVER, tạo ra các VLAN 10 (SALES), 20 (ACCOUNTING), 30 (ENGINEERING)

DL1#vlan database
DL1(vlan)#vtp server  Thiết lập chế độ VTP server mode
DL1(vlan)#vtp domain VNPRO  đặt switch DL1 vào domain VNPRO
DL1(vlan)#vlan 10 name SALES  Tạo VLAN 10 và đặt tên là SALES
VLAN 10 added:
Name: SALES
DL1(vlan)#vlan 20 name ACCOUNTING
VLAN 20 added:
Name: ACCOUNTING
DL1(vlan)#vlan 30 name ENGINEERING
VLAN 30 added:
Name: ENGINEERING
DL1(vlan)#apply  Lưu cấp hình vào file vlan.dat
APPLY completed.
DL1(vlan)#exit
APPLY completed.
Exiting....
DL1#

 Một switch chỉ thuộc 1 VTP domain
Mặc định switch ở chế độ VTP server mode
3. Kích hoạt trunking trên cổng Fa0/1 và cho phép tất cả các VLAN qua trunk:

DL1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
DL1(config)#int f0/1
DL1(config-if)#switchport mode trunk
DL1(config-if)#switchport trunk encapsulation isl  đóng gói kiểu isl (hoặc dot1q) để đi qua đường trunk
DL1(config-if)#switchport trunk allowed vlan all  Cho phép tất cả các VLAN qua trunk
DL1(config-if)#exit
DL1(config)#

 Giả sử ta chỉ muốn cho phép các VLAN 10, 20, 30 ta dùng lệnh:
DL1(config-if)#switchport trunk allowed vlan 10
DL1(config-if)#switchport trunk allowed vlan 20
DL1(config-if)#switchport trunk allowed vlan 30
4. Gán các port vào VLAN tương ứng

DL1(config)#int f0/4
DL1(config-if)#switchport mode access  Cấu hình cổng ở access mode
DL1(config-if)#switchport access vlan 10  cấu hình cổng vào vlan 10
!–– Mỗi access port chỉ phục vụ cho một VLAN
DL1(config-if)#int f0/5
DL1(config-if)#switchport mode access
DL1(config-if)#switchport access vlan 10
DL1(config-if)#int f0/6
DL1(config-if)#switchport mode access
DL1(config-if)#switchport access vlan 10

DL1(config)#int f0/7
DL1(config-if)#switchport mode access
DL1(config-if)#switchport access vlan 20
DL1(config-if)#int f0/8
DL1(config-if)#switchport mode access
DL1(config-if)#switchport access vlan 20
DL1(config-if)#int f0/9
DL1(config-if)#switchport mode access
DL1(config-if)#switchport access vlan 20

DL1(config)#int f0/10
DL1(config-if)#switchport mode access
DL1(config-if)#switchport access vlan 30
DL1(config-if)#int f0/11
DL1(config-if)#switchport mode access
DL1(config-if)#switchport access vlan 30
DL1(config-if)#int f0/12
DL1(config-if)#switchport mode access
DL1(config-if)#switchport access vlan 30
5. Xem cấu hình vừa thực hiện

DL1#sh vlan brief

VLAN Name Status Ports
---- -------------------------------- --------- ------------------------------
1 default active Fa0/2, Fa0/3, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24, Gi0/1, Gi0/2
10 SALES active Fa0/4, Fa0/5, Fa0/6
20 ACCOUNTING active Fa0/7, Fa0/8, Fa0/9
30 ENGINEERING active Fa0/10, Fa0/11, Fa0/12
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
DL1#
Cấu hình trên Switch AL1 làm VTP Client
1. Đặt hostname, mật khẩu và cấu hình management vlan trên DL1:

Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname AL1
AL1(config)#enable mật khẩu cisco
AL1(config)#line vty 0 15
AL1(config-line)#mật khẩu cisco
AL1(config-line)#login
AL1(config-line)#exit
AL1(config)#int vlan 1
AL1(config-if)#ip address 192.168.1.2 255.255.255.0
AL1(config-if)#end
AL1#

2. Thiết lập VTP domain là VNPRO, VTP mode là CLIENT

AL1#vlan database
AL1(vlan)#vtp client
AL1(vlan)#vtp domain VNPRO
AL1(vlan)#exit
In CLIENT state, no apply attempted.
Exiting....
AL1#

3. Kích hoạt trunking trên cổng Fa0/1 và cho phép tất cả các VLAN qua trunk:

AL1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
AL1(config)#int f0/1
AL1(config-if)#switchport mode trunk
AL1(config-if)#switchport trunk encapsulation isl  đóng gói kiểu isl (hoặc dot1q) để đi qua đường trunk
AL1(config-if)#switchport trunk allowed vlan all  Cho phép tất cả các VLAN qua trunk
AL1(config-if)#exit
AL1(config)#

4. Áp đặt các port chỉ định vào VLAN tương ứng

AL1(config)#int f0/4
AL1(config-if)#switchport mode access
AL1(config-if)#switchport access vlan 10
AL1(config-if)#int f0/5
AL1(config-if)#switchport mode access
AL1(config-if)#switchport access vlan 10
AL1(config-if)#int f0/6
AL1(config-if)#switchport mode access
AL1(config-if)#switchport access vlan 10

AL1(config)#int f0/7
AL1(config-if)#switchport mode access
AL1(config-if)#switchport access vlan 20
AL1(config-if)#int f0/8
AL1(config-if)#switchport mode access
AL1(config-if)#switchport access vlan 20
AL1(config-if)#int f0/9
AL1(config-if)#switchport mode access
AL1(config-if)#switchport access vlan 20

AL1(config)#int f0/10
AL1(config-if)#switchport mode access
AL1(config-if)#switchport access vlan 30
AL1(config-if)#int f0/11
AL1(config-if)#switchport mode access
AL1(config-if)#switchport access vlan 30
AL1(config-if)#int f0/12
AL1(config-if)#switchport mode access
AL1(config-if)#switchport access vlan 30

5. Xem cấu hình vừa thực hiện

AL1#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- ---------------------------
1 default active Fa0/2, Fa0/3
10 SALES active Fa0/4, Fa0/5, Fa0/6
20 ACCOUNTING active Fa0/7, Fa0/8, Fa0/9
30 ENGINEERING active Fa0/10, Fa0/11, Fa0/12
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
1002 fddi 101002 1500 - 0 - - - 0 0
1003 tr 101003 1500 - 0 - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
AL1#
Kiểm tra
1. Kiểm tra cổng Fa0/1 đã hoạt động chưa

AL1#show int f0/1
FastEthernet0/1 is up, line protocol is up  Cổng đã hoạt động
Hardware is Fast Ethernet, address is 00b0.64c9.cd41 (bia 00b0.64c9.cd41)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not set
Auto-duplex (Full), Auto Speed (100), 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
...

2. Kiểm tra cổng Fa0/1 đã kích hoạt trunking và đúng kiểu encapsulation chưa

AL1#sh int f0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk  Cổng F0/1 hoạt động ở chế độ trunk mode
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl  Kiểu đóng gói là isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL  Cho phép tất cả các VLAN qua kết nối trunk
Trunking VLANs Active: 1,10,20,30  Các VLAN hiện hành đang hoạt động
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
AL1#

3. Kiểm tra revision number trên client có đồng bộ với server chưa

AL1#sh vtp status
VTP Version : 2
Configuration Revision : 2  số revision number
Maximum VLANs supported locally : 68
Number of existing VLANs : 8
VTP Operating Mode : Client  Switch hoạt động ở chế độ client
VTP Domain Name : VNPRO  Switch thuộc domain VNPRO
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xDC 0x45 0xB2 0xD9 0x5B 0x7A 0x50 0x19
Configuration last modified by 192.168.1.2 at 3-1-93 01:54:06
AL1#

DL1#sh vtp status
VTP Version : 2
Configuration Revision : 2
Maximum VLANs supported locally : 1005
Number of existing VLANs : 8
VTP Operating Mode : Server
VTP Domain Name : VNPRO
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xDC 0x45 0xB2 0xD9 0x5B 0x7A 0x50 0x19
Configuration last modified by 192.168.1.2 at 3-1-93 01:54:06
Local updater ID is 192.168.1.2 on interface Vl1 (lowest numbered VLAN interface
found)
DL1#

 Revision number là một trong những thông số quan trọng của VTP. Mỗi khi VTP server thay đổi VLAN database thì sẽ tăng giá trị revision lên 1 và thực hiện quảng cáo VLAN database này. Các thiết bị có số revision nhỏ hơn phải chấp nhận VLAN database có số revision lớn hơn.

Nếu VTP server xoá bỏ tất cả các VLAN & có số revision cao nhất thì các thiết bị khác cũng sẽ bị xoá VLAN.

4. Kiểm tra số lần gửi và nhận thông tin trunking

DL1#sh vtp counters
VTP statistics:
Summary advertisements received : 18
Subset advertisements received : 5
Request advertisements received : 1
Summary advertisements transmitted : 12
Subset advertisements transmitted : 2
Request advertisements transmitted : 0
Number of config revision errors : 0
Number of config digest errors : 0
Number of V1 summary errors : 0
VTP pruning statistics:

Trunk Join Transmitted Join Received Summary advts received from
non-pruning-capable device
---------------- ---------------- ---------------- ---------------------------
Fa0/1 0 0 0
DL1#

AL1#sh vtp counters
VTP statistics:
Summary advertisements received : 13
Subset advertisements received : 2
Request advertisements received : 0
Summary advertisements transmitted : 20
Subset advertisements transmitted : 6
Request advertisements transmitted : 1
Number of config revision errors : 0
Number of config digest errors : 0
Number of V1 summary errors : 0

VTP pruning statistics:

Trunk Join Transmitted Join Received Summary advts received from
non-pruning-capable device
-->đọc tiếp...

How to set up a Cisco router as a Web Server

http://ardenpackeer.com/ios-features-management/how-to-set-up-a-cisco-router-as-a-webserver/
Mô tả
–HTTP là một ứng dụng client/server, dùng giao thức vận chuyển TCP. Client chạy trình duyệt Web như Netscape Navigator hay Internet Explorer.
–PC chạy trình duyệt Web, kết nối Ethernet với router VNPro là Web server.
–Bài thực hành này mô tả cách cấu hình router để có thể truy cập và quản lý router bằng chương trình duyệt Web chạy trên PC ở địa chỉ 10.10.3.77.

Cấu hình
VNPro
!
hostname VNPro
!
enable password cisco
!
no ip domain-lookup
!
interface Ethernet 0
ip address 10.10.3.100 255.255.255.0
!
ip http server  cho phép router hoạt động như HTTP server
!-–- lệnh này cho phép router trả lời HTTP request từ một Web client
ip classless
!
line console 0
password cisco
login
line vty 0 4
login
!
end
Tại PC
Đia chỉ IP là 10.10.3.1/24
Kiểm tra
Kiểm tra kết nối giữa PC và router bằng lệnh ping trên PC.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.
C:\>ping 10.10.3.100

Pinging 10.10.3.100 with 32 bytes of data:
Reply from 10.10.3.100: bytes=32 time<1ms TTL=255
Reply from 10.10.3.100: bytes=32 time<1ms TTL=255
Reply from 10.10.3.100: bytes=32 time<1ms TTL=255
Reply from 10.10.3.100: bytes=32 time<1ms TTL=255

Ping statistics for 10.10.3.100:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms
C:\>
Chạy chương trình duyệt Web. Nhập địa chỉ của router VNPro trên thanh Address và nhấn Enter
–Màn hình login sẽ xuất hiện
–Nhập User name: cisco hoặc VNPro; Mật khẩu: cisco (mật khẩu này là enable mật khẩu được đặt trên router trước đó).
this content's illegal under copyright laws. "he he" (^-^)
-->đọc tiếp...

Excellent job guys - Dynagen Image Cisco

7200 (7206 only)
Chassis type:
- STD
- VXR
NPE:
- npe-100
- npe-150
- npe-175
- npe-200
- npe-225
- npe-300
- npe-400
- npe-g1
- npe-g2
Cards:
- C7200-IO-FE (FastEthernet, slot 0 only)
- C7200-IO-2FE (FastEthernet, 2 ports, slot 0 only)
- C7200-IO-GE (GigabitEthernet, slot 0 only)
- PA-FE-TX (FastEthernet)
- PA-2FE-TX (FastEthernet, 2 ports)
- PA-4E (Ethernet, 4 ports)
- PA-8E (Ethernet, 8 ports)
- PA-4T+ (Serial, 4 ports)
- PA-8T (Serial, 8 ports)
- PA-A1 (ATM)
- PA-POS-OC3 (POS)
- PA-GE (GigabitEthernet)

===========
3660
3640
3620
Cards:
- NM-1E (Ethernet, 1 port)
- NM-4E (Ethernet, 4 ports)
- NM-1FE-TX (FastEthernet, 1 port)
- NM-16ESW (Ethernet switch module, 16 ports)
- NM-4T (Serial, 4 ports)
- Leopard-2FE (Cisco 3660 FastEthernet in slot 0, automatically used)

===========
2691
3725
3745
Cards:
- NM-1FE-TX (FastEthernet, 1 port)
- NM-4T (Serial, 4 ports)
- NM-16ESW (Ethernet switch module, 16 ports)
- GT96100-FE (2 integrated ports, automatically used)

===========
2610
2611
2620
2621
2610XM
2620XM
2621XM
2650XM
2651XM
Cards:
- NM-1E (Ethernet, 1 port)
- NM-4E (Ethernet, 4 ports)
- NM-1FE-TX (FastEthernet, 1 port)
- NM-16ESW (Ethernet switch module, 16 ports)
-->đọc tiếp...

16 tháng 1, 2008

Để định tuyến được các VLAN

Khi đã chia được VLAN trên switch, giả sử thành 4 VLAN. Làm thế nào để định tuyến được các VLAN đó.
Nếu ta dùng 4 con router nối vào Switch để định tuyến 4 VLAN đó thì cồng kềnh quá (có vẻ không tiết kiệm)
Hướng giải quyết:
Khi bạn chia 4 vlan trong 1 cai switch thì giống như bạn có 4 cái switch vậy riêng biệt vậy, để các Vlan kết nối được với nhau thì bạn cần có thêm router, port từ switch kết nối lên router phải được cấu hình trunking. Port trên router phải là port tốc độ 10/100Mbps, và IOS hỗ trợ chức năng Vlan Trunking.
Nếu bạn dùng switch layer 3 thì không cần router cũng có thể làm cho các vlan kết nối với nhau được.
Giải thích:
Để các Vlan này có thể communicate với nhau,bắt buộc phải dùng L3 routing.
Bạn cần phải dành ra 1 port(Fast ethernet) để làm trunk port.Khi ấy,đường nối từ Fast ethernet của router đến port đó được gọi là đường trunking.
Thế thì đường trunking có vai trò gì trong việc liên lạc giữa các VLAN.?
Khi đã có đường trunking,các traffic qua lại giữa các vlan đều đi qua đây,trên đó các frame sẽ được gắn 1 "biển số phản quang" gọi là VLAN ID.
Router sẽ dựa vào "biển số"này để routing chúng đến đúng nơi.
Để làm được việc này,interface Fastethernet của router sẽ được chia ra làm nhiểu sub-interface(tương ứng với số vLA).Công việc của các
sub-int này là làm gateway cho các host bên trong mỗi VLAN.

Ta hoàn toàn có thể làm được việc này chỉ với 1 switch.
Để routing giữa các VlAN,bạn cần hy sinh 1 port để làm trunk port(phài là fast ethernet).Đối với catalyst 1900 thì đó là 2 port 23 và 24(hình như có ký hiệu A,B gì đó),còn 2900 trở lên thì vô tư,port nào cũng được.
Lúc này, trunk port sẽ nối với interface Fast của router để tạo nên đường trunking.
Mọi việc sau đó chắc là ai cũng nắm rồi.
Về cấu hình,bạn chia ra thành 3 công đoạn:
1.Cấu hình trunk port trước
Vấn đề cần chú ý ở đây là chuẩn encapsulation.ISL là chuẩn nội bộ của Cisco,còn dot 1q là chuẩn chung.Nếu trunk port và interface của router khác nhau về encapsulation,thì các VLAN sẽ k bao giờ nói chuyện với nhau được.Lý do là lúc này router sẽ k nhận ra field VLAN ID nằm ở đâu?
2.access các port vào các VLAN,bạn cứ tùy thích mà chọn lựa số VLAN và số port tương ứng.
3.Routing giữa các VLAN:
Để làm việc này,int của router sẽ được chia ra làm nhiều sub-int tươngn ứng số VLAN.Các PC nối vào VLAN nào sẽ có default gateway là sub-int cho VLAN đó.Ngược lại,trên router bạn cũng cần route cụ thể về từng VLAN(=1 subnet) sẽ qua sub-int nào.
-->đọc tiếp...

Mot thac mac nho khi thiet lap VLAN(ISL hoặc Dot1Q)

ICND đòi hỏi phải xác định được phương thức trunking dùng trên các interface ethernet. Cisco hỗ trợ các phương thức trunking như sau:
■ InterSwitch Link (ISL) - Ethernet
■ IEEE’s 802.1Q (Dot1Q) - Ethernet
■ LANE - ATM
■ 802.10 - FDDI

Như vậy, nếu giữa 2 switch có trunking qua interface fastethernet thì phải dùng ISL hoặc Dot1Q.
-->đọc tiếp...

xây dựng topology de thuc hanh VLAN

autostart = false
[localhost]
port = 7200
udp = 10000
workingdir = D:\TRAINING\VLAN_PC
ghostios = true
sparsemem = true
[[7200]]
image = C:\Program Files\Dynamips\images\c7200-adventerprisek9-mz.124-11.T.bin
ram = 256
idlepc = 0xffffffff8000b354 # so nay tuy vao may ban dung idlepc get
[[3745]]
image = C:\Program Files\Dynamips\images\c3745-adventerprisek9-mz.124-12.bin
ram = 160
idlepc = 0xffffffff8000a89c # so nay tuy vao may ban dung idlepc get
slot1 = NM-16ESW #khai bao Switch
[[router R1]]
model = 7200
console = 2000
F0/0 = SW1 F1/0

[[router SW1]]
model = 3745
console = 2001
F1/10 = NIO_gen_eth:\Device\NPF_{31AC8C18-4890-4BC5-A1F0-637C4207965D}
Nối cổng F1/10 với card mạng máy của bạn. số này thay đổi theo từng card mạng.
Dùng các route cũ để làm pc kết nối đến SW1. tôi đề nghị dùng 1900 ram cap cho con nay 32 là đủ rồi.
-->đọc tiếp...

Chia VLAN trên SW có 2 bước

Chia VLAN trên SW có 2 bước:
1. Tạo VLAN
2. Gán SW port vào VLAN có 2 kiểu:
- Static: áp dụng cho các mạng nhỏ và gán port vào VLAN nhân công
- Dynamic

Nếu bạn sử dụng SW Catalyst 2900XL tạo VLAN static thì bạn có thể cấu hình như sau:
1. Tạo VLAN
vlan database
vlan #vlan name vlanname
Chú ý: không nên sử dụng VLAN 1 nếu không muốn cho telnet vào SW
2. Gán SW port vào VLAN
interface FastEthernet 0/n
switchport mode access
switchport access vlan
số thứ tự (số hiệu) của Vlan
VD:
vlan database
- tao vlan 10 dat ten la nguyen
#>vlan 10 name nguyen
- tao vlan 20 dat ten thuy
#>vlan 20 name thuy

vay la ta co 2 vlan10 va vlan20 mac dinh co them vlan1
gan port vao vlan
#>config
interface FastEthernet 0/1
switchport mode access
switchport access vlan10
exit
interface FastEthernet 0/2
switchport mode access
switchport access vlan20
exit
lenh tren gan FA0/1 vao vlan10
lenh tren gan FA0/2 vao vlan20
-->đọc tiếp...

15 tháng 1, 2008

Phân biệt đầu đầu DCE & đầu DTE (phụ thuộc vào kết nối->config clock)

Ví dụ: [[ROUTER R1]]
s1/0 = R2 s1/0
Thì s1/0 ở Router R1 sẽ là đầu DCE ( bạn sẽ config clock rate tại đây) còn đầu s1/0 của Router R2 sẽ là đầu DTE!

Xin bổ sung một chút.
Nếu các bạn muốn máy tính của mình cũng tham gia vào hệ thống ảo này, thì sau khi cài đặt Dynagen, sẽ có một file ở dạng DOS là NetWork Device List, nhấp vào đây sẽ có thông tin về tất cả các card mạng mà bạn có.
Trong file định nghĩa bạn thêm câu lệnh
F0/0 = NIO_gen_eth:\Device\NPF_{}
Trong dấu ngoặc sẽ là số hiệu card mạng mà bạn muốn PC dùng nó để connect ra với router.
Rồi tiến hành đặt IP bình thường.
Bạn chạy Dynamip Server nhé, sau đó chạy Network Devices List . Sau đó nó sẽ hiện ra mã code card NIC của bạn.VD như sau : NIO_gen_eth:\Device\NPF_{AA705EF7-D699-413E-9FE4-525C9F9477FB}
Bạn copy cái dòng này và thêm vào trong File .Net.
VD như bạn muốn nối cồng Fa0/0 của Router A với Card NIC thì ở phần của Router A trong File .Net bạn thêm dòng như sau:

[[ROUTER A]]
F0/0 = NIO_gen_eth:\Device\NPF_{AA705EF7-D699-413E-9FE4-525C9F9477FB}
-->đọc tiếp...

Cau hinh lab Mau cho DYnagen

#Disable tat ca cac router trong mo hinh. Dong tac nay lam giam tai hoat dong cua CPU, tranh su co treo may.
autostart = False
#DYNAGEN cho phep 1 mo hinh chay tren nhieu may PC, nguoi su dung chi khai bao ten may kem voi port UDP de DYNAGEN hoat dong.
#Mo hinh mang lon se duoc chia ra tren cac PC, mot so router chay tren PC 1, cac router khac chay tren PC 2, 3...
#Khai bao cac may tinh theo kieu [computername:7200], hoac [192.168.1.1:7200], hoac neu chi su dung 1 may khai bao [localhost:7200]
#Khai bao PC 1
[Localhost:7200]
#Xac dinh port UDP cho PC 1. DYNAGEN su dung port UDP nay de ket noi cac may tinh trong mang.
udp = 10000
#Chi duong dan ma DYNAGEN se tao ra cac file IOS ao, NVRAM ao, FLASH ao,...Day la noi se luu lai cau hinh bai lab, lan vao tiep theo se su dung cau hinh da luu.
workingdir = E:\Soft\DYNAGEN\working1

#DYNAGEN cho phep su dung IOS cua nhieu router nhu 26xx, 36xx,37xx, 7200. Theo kinh nghiem, nen chon router la 7200, cac router co module switch la 3725, 3745.
######################
#Dinh nghia cac loai router
######################
#Dinh nghia router 7200
[[7200]]
#Chi dinh IOS se su dung de chay cho router 7200. IOS nay nen duoc giai nen de PC khoi giai nen khi chay, dong thoi mot so tinh nang nhu ghostios, sparsesmem cung yeu cau giai nen IOS.
image = C:\Program Files\Dynamips\images\C7200-JK.BIN
#Chon gia tri idlepc cho IOS. Gia tri idlepc se tuy thuoc vao IOS va CPU dang su dung. idlepc co tac dung lam giam tai cho CPU, giup PC co the chay nhanh va nhieu route hon.
idlepc = 0x60753e54
#Chon Engine xu ly cua router, engine cang lon cang manh, tuy nhien doi hoi cang nhieu RAM.
#Cac Network Processing Engine (npe) cua 7200 gom 100, 150,175, 200, 225, 300, 400. Thuong chon 200 hoac 400.
npe = npe-400
#Cap phat RAM cho router. RAM duoc cap phat tuy thuoc vao IOS. Cac ban IOS 12.4 tro len phai su dung it nhat 128BM cho 1 router, IOS 12.3 co the su dung 96 MB.
ram = 96
#Su dung RAM ao (virtual memory cua PC) de chay DYNAGEN. Neu gia tri mmap = False, DYNAGEN se lay RAM that de chay cho router.
mmap = True
#Su dung Ghost IOS cho cac router cung loai. Dung de tiet kiem dung luong o cung (neu khong co lenh nay, ung voi moi router se co 1 IOS ao).
#Lenh nay thiet lap 1 IOS dung chung cho tat ca router cung loai. Doi hoi phai giai nen cho IOS.
ghostios = True
#Thiet lap sparsesmem
sparsesmem = True
#Dinh nghia router 3725
[[3725]]
image = C:\Program Files\Dynamips\images\C3725-AD.BIN
#idlepc = 0x602893ac
ram = 128
mmap = True
ghostios = True
sparsesmem = True
#Khai bao cac router trong mo hinh lab. Moi bai lab nen tao mot thu muc rieng de quan ly. Copy file cau hinh nay vao thu muc do. Chinh sua lai duong dan workingdir cho phu hop voi thu muc.
#Mo hinh nay nen chua nhieu nhieu router, switch (thuc chat la router co module switch) va 1 FRSW.
#Khai bao router R1
[[Router R1]]
#Chi dinh loai router (7200 hay 3725)
model = 7200
#Chi dinh port console cho thiet bi R1
console = 2001
#Cho router khoi dong va tim NVRAM de load cau hinh cu vao.
confreg = 0x2102
#Gan cac module can dung vao router R1. Nen de nguyen theo cau hinh sau day. Can su dung interface nao thi bat interface do len.
slot1 = PA-2FE-TX #Slot 1 se gan module gom 2 cong FastEthernet.
slot2 = PA-8T #Slot 2 se gan module gom 8 cong Serial.
#Ket noi cac interface cua router voi nhau. Phan nay tam thoi de trong. Tuy vao bai lab cu the, tuy mo hinh cu the se co ket noi thich hop.
#Vi du ket noi nhu sau: F0/0 = R2 F0/1, nghia la interface F0/0 cua router R1 se ket noi voi interface F0/1 cua router R2. Tuy nhien, ben phia R2 khong can dinh nghia ket noi nguoc lai.
#Vi du ket noi vao FRSW: S2/0 = FRSW 1, nghia la interface cua router R1 se ket noi vao interface 1 cua FRSW.
#Chon file cau hinh co ban da co san cho router. Dong nay nen bat len o lan dau tien chay mo hinh lab nao do.
#Nhung lan chay sau doi voi cung bai lab do khong can co dong nay, tat dong nay bang cach them dau "#" vao dau dong. File cau hinh khoi tao (initial) phai co truoc.
#cnfg = E:\Soft\DYNAGEN\initial\R1.txt
#Khai bao router R2
[[Router R2]]
model = 7200
console = 2002
confreg = 0x2102
slot1 = PA-2FE-TX
slot2 = PA-8T
#Ket noi
#cnfg = E:\Soft\DYNAGEN\initial\R2.txt

#Khai bao router R3
[[Router R3]]
model = 7200
console = 2003
confreg = 0x2102
slot1 = PA-2FE-TX
slot2 = PA-8T
#Ket noi
#cnfg = E:\Soft\DYNAGEN\initial\R3.txt
#Khai bao router R4
[[Router R4]]
model = 7200
console = 2004
confreg = 0x2102
slot1 = PA-2FE-TX
slot2 = PA-8T
#Ket noi

#cnfg = E:\Soft\DYNAGEN\initial\R4.txt
#Khai bao router R5
[[Router R5]]
model = 7200
console = 2005
confreg = 0x2102
slot1 = PA-2FE-TX
slot2 = PA-8T
#Ket noi
#cnfg = E:\Soft\DYNAGEN\initial\R5.txt

#Khai bao router R6
[[Router R6]]
model = 7200
console = 2006
confreg = 0x2102
slot1 = PA-2FE-TX
slot2 = PA-8T
#Ket noi
#cnfg = E:\Soft\DYNAGEN\initial\R6.txt
#Khai bao switch SW1
[[Router SW1]]
model = 3725
console = 2007
confreg = 0x2102
slot1 = NM-4T #Module gom 4 interface Serial cua router 3725
slot2 = NM-16ESW #Module switch L3 gom 16 interface FastEthernet cua router 3725
#Ket noi
#cnfg = E:\Soft\DYNAGEN\initial\SW1.txt
#Khai bao switch SW2
[[Router SW2]]
model = 3725
console = 2008
confreg = 0x2102
slot1 = NM-4T
slot2 = NM-16ESW
#Ket noi
#cnfg = E:\Soft\DYNAGEN\initial\SW2.txt
#Khai bao switch SW3
[[Router SW3]]
model = 3725
console = 2009
confreg = 0x2102
slot1 = NM-4T
slot2 = NM-16ESW
#Ket noi
#cnfg = E:\Soft\DYNAGEN\initial\SW3.txt
#Khai bao switch SW4
[[Router SW4]]
model = 3725
console = 2010
confreg = 0x2102
slot1 = NM-4T
slot2 = NM-16ESW
#Ket noi
#cnfg = E:\Soft\DYNAGEN\initial\SW4.txt
#Khai bao Terminal Server. Terminal Server giup de kiem soat bai lab hon. Chi can telnet vao router Terminal, Terminal se co ket noi qua card mang loopback cua PC, cho phep truy cap vao cac router khac #bang line console. Xem them cau hinh mau cua router Terminal.
[[Router Terminal]]
model = 7200
console = 2011
F0/0 = NIO_gen_eth:\Device\NPF_{4B7434E6-05F2-4801-8B9A-1997B3B299FF}
# Network device list:
# \Device\NPF_GenericDialupAdapter : Network adapter 'Adapter for generic dialup and VPN capture' on local host
# \Device\NPF_{4B7434E6-05F2-4801-8B9A-1997B3B299FF} : Network adapter 'MS LoopBack Driver' on local host
# \Device\NPF_{70EDE629-6193-4F25-B107-C5CFA31D6CCD} : Network adapter 'VMware Virtual Ethernet Adapter' on local host
# \Device\NPF_{73C2E9B8-AEC8-47E0-A5E9-F0852549F5FE} : Network adapter 'VMware Virtual Ethernet Adapter' on local host
cnfg = E:\Soft\DYNAGEN\initial\Terminal.txt
#Khai bao Frame-Relay Switching co ten la FRSW
# [[FRSW FRSW]]
#R1 noi voi FRSW
# 1:100 = 2:100
# 1:200 = 3:200
# 1:400 = 4:400
#R2 noi voi FRSW
# 2:500 = 3:500
# 2:600 = 4:600
#R3 noi voi FRSW
# 3:700 = 4:700
#R4 noi voi FRSW. Khong co cau hinh gi them vi ket noi da duoc dinh nghia tren day. Hay nho rang: ket noi trong DYNAGEN chi can dinh nghia 1 lan, chi can 1 chieu, khong can chieu nguoc lai.
Thay đổi chương trình telnet mặc định thành Secure CRT
Bạn vào thư mục cài đặt Dynagen mở file config.ini
Tìm đến đoạn
[code]# Uncomment below for Windows
telnet = start telnet %h %p
# Or better yet for Terra Term SSH users:
#telnet = C:\progra~1\TTERMPRO\ttssh.exe %h %p /W=%d /T=1
# For PuTTY users:
#telnet = start C:\progra~1\PuTTY\putty.exe -telnet %h %p
# For SecureCRT
#telnet = start C:\progra~1\SecureCRT\SecureCRT.EXE /script c:\progra~1\dynamips\securecrt.vbs /arg %d /T /telnet %h %p & sleep 1[code]
Bỏ thêm dấu # vào trước câu lệnh telnet = start telnet %h %p
Thêm vào trước đó câu lệnh
telnet = start C:\Progra~1\Secure~1.0\SecureCRT.EXE %h %p
-->đọc tiếp...
BlogWeb: tạo từ Blog của Google
Nội dung: lấy từ nhiều Nguồn khác nhau.
Mục đích: note lại bài Hướng dẫn hay và Đáng đọc.
Kết quả: nghiện Internet Nặng.
Tương lại: xuống lỗ Vẫn Nghiện nếu không có ai giúp.
Blog Web của: Trí Dũng đến từ Việt Nam - Liên kết đến trang Blog Cá Nhân
Tôi biết (^_^)
Thông tin về Tác giả. Chi Tiết
Sử dụng (FireFox | Google Chrome on Ubuntu) để xem tốt nhất. Học Nhiều Hơn Tại Đây
©2009 Google Blogger - HuuNguyen's Home